PDA

View Full Version : Is It Turbo Stall


THEKID17
01-20-2008, 01:19 PM
Hey, I have a 97 f250 7.3, and wont to know what I can do to make it faster.
I have put a K&N air kit and a BD downpipe on it. The next thing Im thinking about puting on it is a chip, but there is a problem. The truck has 309k miles on it and is acting like its having turbo problems. What I mean is when the truck is runing at 1500 to 2500rpm it will drop 500rpm without lossing speed. Also there is a soud of rushing air coming from the turbo, not the normal jet sound.
Does any body have an idea what this might be and how to corect it.

Thanks

tjl
01-20-2008, 04:19 PM
Sounds like it might be your EBPV (exhaust back preassure valve) closing. How cold is it when this happens? If it's cold where you'r at than this is normal. You can disconnect it if you want, it'll just take longer for your truck to warm up.

THEKID17
01-20-2008, 06:51 PM
I am not sure the highest the temp has been since it started acting up is 60. I had it in the shop and they said they cleaned the EBPV, that did help for about a day. The only thing that makes me think that is not the EBPV is it will do it even when it has been runing for 30-60min.
How do I disconnect the EBPV, if that fixes it problem solved

tjl
01-20-2008, 08:13 PM
I'm not positive but I think you can disconnect the sensor that tells the valve to close. Sorry I can't be more specific. I'm not real sure where iit is.

Fordpowstroke73
01-22-2008, 10:01 AM
I connector is right around the turbo where it connects to the pedistal. Trace the wires to the EBPV and unplug it. Or take your DP off and gut the thing. Good luck.

BAD_VAN
01-22-2008, 12:53 PM
i would gut the thing. remove it from the turbo and pull the valve out.