PDA

View Full Version : 6.7L twin turbo kit S-300 / S-400


wayne zimmerman
03-21-2009, 03:39 PM
My 6.7l with a set of twins, they work real good, no check eng light.

ChaseN
03-21-2009, 03:49 PM
pics?

dragnsled
03-21-2009, 03:52 PM
Does this make more boost than a pro52:evil...I'm sure it tows better

wayne zimmerman
03-21-2009, 04:33 PM
With the fuel we have going to it right now it runs 55 boost.

dragnsled
03-21-2009, 05:24 PM
15551 Does this actually work? Sorry Wayne I couldn't resist:hehe:

wayne zimmerman
03-21-2009, 05:32 PM
These turbos rrrrrrr sweet 55psi with blow off valves set and 1200 deg EGTs great for towing with XRT 175-HP tune

Compcowboy
03-21-2009, 08:54 PM
very nice setup.

'strokeThis_'07
03-21-2009, 10:18 PM
Looks good man. What size are they?

Jim Fulmer
03-21-2009, 10:19 PM
What's the scoop on your black short bed.

Jim

wayne zimmerman
03-22-2009, 06:40 AM
The twins are a super 64 on top and the big frame S-400 on the button The ??? on my black truck ram 1500 24v p-pumped 675hp

Ga_Mike
03-22-2009, 10:19 PM
Very clean install. Congrads....Got studs yet?

gwhammy
03-23-2009, 07:44 AM
Nice job Wayne! Did you get the bottom turbo hooked up to the stock exhaust like you thought you could?
Oh, the vp we talked about had the seal pushed out of it when I sent it to Area Diesel. They fixed it no cost. Good people. First one they had ever seen!

wayne zimmerman
03-23-2009, 08:24 AM
On the S-400 turbo i machined the 5" exhaust flage to a 4" 3rd gen and used the 3rd gen cast elbow. so the S-400 is in the stock location. I dont have stud in it didnt have maby this week :ft:

01smoker
03-30-2009, 03:41 PM
How bout a video?

silverbullet
03-30-2009, 04:16 PM
Sooooo...you're using blow off valves to control boost??????

TWIN 6.7L
03-30-2009, 07:54 PM
My blow off valves are there for safety on the head gasket, these twins with the wright fueling could range from 60-psi to 90-psi Im running around 55-psi with stock CP3 and stock injectors

Mike Holmen
07-11-2009, 07:29 PM
Those twins like sweet buddy, couple questions for ya. Which exhaust manifold you using? Why you not pushing the boost up past 55psi? Have you oringed the head yet? Which ARPS you using? I can't wait till I get mine so I can mod it up some.

dzchey21
07-11-2009, 07:33 PM
pretty clean set up. i like

wayne zimmerman
07-11-2009, 07:38 PM
the manifold is PDIs, and i dont have the head oringed yet and im using haisley studs :ft: