Advertisement
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Home Who's Online Today's Posts HP Calculator CompD Gift Shop Mark Forums Read
Go Back   Competition Diesel.Com - Bringing The BEST Together > Tech Area- Dodge > Dodge Tech > 94-98 2nd Gen. 12V
Register Members List Timeslips EFI Live Library Invite Your Friends FAQ Calendar Mark Forums Read

Reply
 
Thread Tools
Old 05-10-2018, 10:25 AM   #1
K204DR
 
K204DR's Avatar

Name: K204DR
Title: I'm the Driver
Status: Not Here
Join Date: Jun 2008
Location: TN
Member`s Gallery
Posts: 802
180 pump suddenly no idle?

got a 180 pump, that suddenly decided it didn't want to idle. it would run if you kept your foot on the throttle, so we drove 1.5 hours home. i can adjust the idle up to 1000-1100 and it will run. any ideas? nothing I can find wrong with the gov springs. just got done looking there. protrusion is 052. very strange. its not a fuel flow issue as it has tons of power, just won't idle. we changed the filter just to be safe and it was all clean.
__________________
88 Chevy crewcab 95 6bt nv4500 valair clutch
72 scout II 4BT TH400 1TONS
  Reply With Quote
Old 05-10-2018, 01:57 PM   #2
Yotadzl

Name: Yotadzl
Title: Green Behind the Ears
Status: Not Here
Join Date: Feb 2016
Location: Oregon
Member`s Gallery
Posts: 93
It runs ok otherwise? The governor cuts on the top end like normal? No power change? It sounds like a governor issue. Usually there will be other symptoms along with the idling issue if it is. Can also be a sticky plunger, although usually that will make it miss too.
__________________

'85 Yota Crawler-2l diesel, custom built VE (by me), custom T25 turbo. Slow but fun!
'95 Cummins grampa truck, embarrassingly stock (4wd swap and 700 HP in the works)
'12 Cummins, warranty's up!
  Reply With Quote
Old 05-10-2018, 06:11 PM   #3
K204DR
 
K204DR's Avatar

Name: K204DR
Title: I'm the Driver
Status: Not Here
Join Date: Jun 2008
Location: TN
Member`s Gallery
Posts: 802
no miss, runs perfect going down the road. guess I'm gonna have to get someone to work on it.
__________________
88 Chevy crewcab 95 6bt nv4500 valair clutch
72 scout II 4BT TH400 1TONS
  Reply With Quote
Old 05-11-2018, 11:16 AM   #4
jlbayes
 
jlbayes's Avatar

Name: jlbayes
Title: Too Much Time
Status: Not Here
Join Date: Mar 2011
Location: michigan
Member`s Gallery
Posts: 2,399
Does it run away if you are in neutral or park? Mine is acting VERY similar to what you have going on.
__________________
Jacob, 97 rclb
  Reply With Quote
Old 05-11-2018, 12:19 PM   #5
CorneliusRox
 
CorneliusRox's Avatar

Name: CorneliusRox
Title: Seasoned Rookie
Status: Not Here
Join Date: Dec 2012
Location: Minneapolis, MN
Member`s Gallery
Posts: 3,396
Go buy a thing of power service (or howies or whatever) and try it with that. I had a sticking plunger that was just like that and I started using an additive every tank and haven't had that issue come back in the last 30k!
__________________
Corey - BSME
Thumper - '97 12V Michigan Rust Bucket
Ares - '10 Rust-Free Family Hauler
  Reply With Quote
Old 05-12-2018, 09:33 AM   #6
K204DR
 
K204DR's Avatar

Name: K204DR
Title: I'm the Driver
Status: Not Here
Join Date: Jun 2008
Location: TN
Member`s Gallery
Posts: 802
I have a 1000 mile road trip to make, so I'll be swapping my cranky 215 pump back in I guess. I don't trust the 180 pump. I'll just have to deal with the off idle stutter a little longer I guess on the 215. now i got two pumps needing worked on!
__________________
88 Chevy crewcab 95 6bt nv4500 valair clutch
72 scout II 4BT TH400 1TONS
  Reply With Quote
Old 05-12-2018, 09:35 AM   #7
K204DR
 
K204DR's Avatar

Name: K204DR
Title: I'm the Driver
Status: Not Here
Join Date: Jun 2008
Location: TN
Member`s Gallery
Posts: 802
Quote:
Originally Posted by jlbayes View Post
Does it run away if you are in neutral or park? Mine is acting VERY similar to what you have going on.
Its in a stickshift truck so its always in neutral! haven't had any runaway feeling though, but it kinda gave me the impression that it possibly could.
__________________
88 Chevy crewcab 95 6bt nv4500 valair clutch
72 scout II 4BT TH400 1TONS
  Reply With Quote
Old 05-14-2018, 03:02 PM   #8
jlbayes
 
jlbayes's Avatar

Name: jlbayes
Title: Too Much Time
Status: Not Here
Join Date: Mar 2011
Location: michigan
Member`s Gallery
Posts: 2,399
Ok so I tore into mine Sunday. Something is wrong with the governor. I was only able to take one set of the springs out and I had to fight to get them out. Idle spring was bad enough I had to use needle nose to get it out of the pump.
__________________
Jacob, 97 rclb
  Reply With Quote
Old 05-15-2018, 07:44 PM   #9
K204DR
 
K204DR's Avatar

Name: K204DR
Title: I'm the Driver
Status: Not Here
Join Date: Jun 2008
Location: TN
Member`s Gallery
Posts: 802
interesting. my springs went in and out just fine. I had bosch 4k springs in mine.
__________________
88 Chevy crewcab 95 6bt nv4500 valair clutch
72 scout II 4BT TH400 1TONS
  Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 02:51 AM.

 


Powered by vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright ©2006 - 2018, CompetitionDiesel.com
all information found on this site is property of www.competitiondiesel.com