Advertisement
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Home Who's Online Today's Posts HP Calculator CompD Gift Shop Mark Forums Read
Go Back   Competition Diesel.Com - Bringing The BEST Together > Tech Area- Dodge > Dodge Tech > 03-07 3rd Gen.
Register Members List Timeslips EFI Live Library Invite Your Friends FAQ Calendar Mark Forums Read

Reply
 
Thread Tools
Old 01-10-2019, 12:31 AM   #1
fzL

Name: fzL
Title: Rookie
Status: Not Here
Join Date: May 2016
Member`s Gallery
Posts: 8
Unhappy 06 No Power Struggle Going Up Hills

2006 Dodge Ram 2500 4x4 Shortbed /60 Over injectors/ CTS2 monitor/built 48re/Anarchy Diesel EFI LIVE/

Few months ago I was pulling my 16ft trailer to RV park. It all of the sudden started struggling going up hills, no check engine lights. I did have a check engine code come for the MAP & P2609 intake Air Heater System Performance code unplugged the connector and put dielectric grease on MAP it and cleared code and went away never came back. I still have the code p2609 Intake Air Heater System Performance. I have ordered a new MAP sensor just incase haven't installed it yet. Unplugged FCA and FP jumps to 25,000psi, But under WOT I can only see 21,000psi with 35 pounds of boost and wont push anymore fuel pressure EGTs are at 1200. I use to be able to blow black smoke with the anarchy diesel EFI live now I don't see a lick of smoke at all! PLEASE HELP ME CANT EVEN PULL MY TRAILERS WITH THIS RIG!! Still have stock lift pump, do not have a Fuel Pressure gauge for it.

Last edited by fzL; 01-10-2019 at 12:34 AM.
  Reply With Quote
Old 01-10-2019, 07:01 AM   #2
pushlar84
 
pushlar84's Avatar

Name: pushlar84
Title: pushlar84
Status: Not Here
Join Date: Dec 2009
Location: new york
Member`s Gallery
Posts: 555
U pretty much answered it ur self
No lift pump and 60% without a upgraded cp3
Needs both
__________________
2001 Ram- fuel by Northeast Diesel, 2.6 ED, Allison 1000. Haisley cam, engine & trans built in house
  Reply With Quote
Old 01-10-2019, 11:07 AM   #3
Ghostman
 
Ghostman's Avatar

Name: Ghostman
Title: 24v crazy
Status: Not Here
Join Date: Aug 2012
Location: Victoria, tx
Member`s Gallery
Posts: 2,817
Are you blowing through the transmission?


Sent from my iPhone using Tapatalk
__________________
2002 4wd towing truck
2002 2wd grocery getter
2001 4wd 12v - retired
2006 QCSB 4wd - EFI Live

Quote:
Originally Posted by Joesixpack View Post
VE vs VP....isn't that like watching retard's fight?
  Reply With Quote
Old 01-10-2019, 11:34 AM   #4
fzL

Name: fzL
Title: Rookie
Status: Not Here
Join Date: May 2016
Member`s Gallery
Posts: 8
I have broken the billit input shaft in the tranny and blown forward gears before
  Reply With Quote
Old 01-10-2019, 11:35 AM   #5
fzL

Name: fzL
Title: Rookie
Status: Not Here
Join Date: May 2016
Member`s Gallery
Posts: 8
Quote:
Originally Posted by pushlar84 View Post
U pretty much answered it ur self
No lift pump and 60% without a upgraded cp3
Needs both

So I need to check my lift pump? I have had injectors in over and year and has ran fine up until a couple months ago became really sluggish and no power.
  Reply With Quote
Old 01-10-2019, 12:01 PM   #6
fzL

Name: fzL
Title: Rookie
Status: Not Here
Join Date: May 2016
Member`s Gallery
Posts: 8
Sorry guys I meant 60hp injectors 33% over my fault!!
  Reply With Quote
Old 01-10-2019, 12:42 PM   #7
SPEEDSHIFT
 
SPEEDSHIFT's Avatar

Name: SPEEDSHIFT
Title: Too Much Time
Status: Not Here
Join Date: Jan 2007
Location: San Antonio, TX
Member`s Gallery
Posts: 5,359
Sounds like it is blowing through the transmission to me.
__________________
Bodie @sanglesnail
2003 2500 4x4 auto 6.75 @104
2004 2500 4x4 auto
2005 2500 4x4 auto


Quote:
Originally Posted by Snedge View Post
Anything stock is slow. That's why they invented money.
  Reply With Quote
Old 01-10-2019, 01:12 PM   #8
fzL

Name: fzL
Title: Rookie
Status: Not Here
Join Date: May 2016
Member`s Gallery
Posts: 8
Quote:
Originally Posted by SPEEDSHIFT View Post
Sounds like it is blowing through the transmission to me.
So do I need to have tranny checked out?
  Reply With Quote
Old 01-10-2019, 01:37 PM   #9
CorneliusRox
 
CorneliusRox's Avatar

Name: CorneliusRox
Title: Seasoned Rookie
Status: Not Here
Join Date: Dec 2012
Location: Minneapolis, MN
Member`s Gallery
Posts: 3,642
Quote:
Originally Posted by fzL View Post
So do I need to have tranny checked out?
Just lock the TC in 4th, get going, gun it, and see if the RPM changes faster than the speed.

It should be obvious if the engine is pushing past the clutches.

Also, it's probably worth getting an analog fuel pressure gauge and seeing if pre-CP3 pressure drops. I think you're supposed to have ~10-20psi (don't quote me on that number).
__________________
Corey - BSME
Thumper - '97 12V Michigan Rust Bucket
Ares - '10 Rust-Free Family Hauler
  Reply With Quote
Old 01-10-2019, 08:13 PM   #10
pushlar84
 
pushlar84's Avatar

Name: pushlar84
Title: pushlar84
Status: Not Here
Join Date: Dec 2009
Location: new york
Member`s Gallery
Posts: 555
Quote:
Originally Posted by fzL View Post
So I need to check my lift pump? I have had injectors in over and year and has ran fine up until a couple months ago became really sluggish and no power.
Makes more sense

Id still check lift pump pressure tho cause its still dropping rail
__________________
2001 Ram- fuel by Northeast Diesel, 2.6 ED, Allison 1000. Haisley cam, engine & trans built in house
  Reply With Quote
Old 01-10-2019, 08:14 PM   #11
pushlar84
 
pushlar84's Avatar

Name: pushlar84
Title: pushlar84
Status: Not Here
Join Date: Dec 2009
Location: new york
Member`s Gallery
Posts: 555
Or relief valve leaking too
__________________
2001 Ram- fuel by Northeast Diesel, 2.6 ED, Allison 1000. Haisley cam, engine & trans built in house
  Reply With Quote
Old 01-10-2019, 08:57 PM   #12
fzL

Name: fzL
Title: Rookie
Status: Not Here
Join Date: May 2016
Member`s Gallery
Posts: 8
Quote:
Originally Posted by pushlar84 View Post
Makes more sense

Id still check lift pump pressure tho cause its still dropping rail
got a gauge for the lift pump just haven't had time to hook up yet, anyone know what pressure I should be seeing at idle and WOT?

also have the pressure relief valve coming from TODD @ TCdiesel Saturday.
  Reply With Quote
Old 01-10-2019, 08:57 PM   #13
fzL

Name: fzL
Title: Rookie
Status: Not Here
Join Date: May 2016
Member`s Gallery
Posts: 8
Quote:
Originally Posted by CorneliusRox View Post
Just lock the TC in 4th, get going, gun it, and see if the RPM changes faster than the speed.

It should be obvious if the engine is pushing past the clutches.

Also, it's probably worth getting an analog fuel pressure gauge and seeing if pre-CP3 pressure drops. I think you're supposed to have ~10-20psi (don't quote me on that number).
works great when the torque converter locks in.
  Reply With Quote
Old 01-11-2019, 09:13 AM   #14
CorneliusRox
 
CorneliusRox's Avatar

Name: CorneliusRox
Title: Seasoned Rookie
Status: Not Here
Join Date: Dec 2012
Location: Minneapolis, MN
Member`s Gallery
Posts: 3,642
Quote:
Originally Posted by fzL View Post
works great when the torque converter locks in.
So if you're pulling and you lock in 2nd or 3rd, you don't have a power issue? Only when the TC is unlocked?

Quote:
Originally Posted by fzL View Post
got a gauge for the lift pump just haven't had time to hook up yet, anyone know what pressure I should be seeing at idle and WOT?

also have the pressure relief valve coming from TODD @ TCdiesel Saturday.
16-18 psi at all times. If it drops, you're lift pump doesn't have enough flow to support your larger injectors and tune.
__________________
Corey - BSME
Thumper - '97 12V Michigan Rust Bucket
Ares - '10 Rust-Free Family Hauler

Last edited by CorneliusRox; 01-11-2019 at 09:21 AM.
  Reply With Quote
Old 01-11-2019, 09:21 AM   #15
CorneliusRox
 
CorneliusRox's Avatar

Name: CorneliusRox
Title: Seasoned Rookie
Status: Not Here
Join Date: Dec 2012
Location: Minneapolis, MN
Member`s Gallery
Posts: 3,642
----------------------
__________________
Corey - BSME
Thumper - '97 12V Michigan Rust Bucket
Ares - '10 Rust-Free Family Hauler
  Reply With Quote
Old 01-16-2019, 04:58 PM   #16
tylerltr450
 
tylerltr450's Avatar

Name: tylerltr450
Title: Wanna Be Hacker
Status: Not Here
Join Date: Aug 2014
Location: Coal Region, PA
Member`s Gallery
Posts: 168
Quote:
Originally Posted by CorneliusRox View Post
16-18 psi at all times. If it drops, you're lift pump doesn't have enough flow to support your larger injectors and tune.

My lift pump doesnt run at 16-18psi and my truck runs fine. As long as there is pressure the truck should run ok Heck mine drops to 5psi when im on it good and i still get full RP.

Also why not log your truck to see demanded vs actual pressure to figure out if your CP3 is on its way out.
__________________
2006 Red 5.9 Traction Bars, S&B Intake, ATS intake horn, EFI Live, Borg Warner S363 Turbo, Industrial Injection 60hp Injectors. Auto to nv5600(Complete). SBC 3600

Custom EFI Live Tuning
FullPullPerformance@gmail.com

Last edited by tylerltr450; 01-16-2019 at 05:06 PM.
  Reply With Quote
Old 01-16-2019, 07:01 PM   #17
fzL

Name: fzL
Title: Rookie
Status: Not Here
Join Date: May 2016
Member`s Gallery
Posts: 8
Quote:
Originally Posted by tylerltr450 View Post
My lift pump doesnt run at 16-18psi and my truck runs fine. As long as there is pressure the truck should run ok Heck mine drops to 5psi when im on it good and i still get full RP.

Also why not log your truck to see demanded vs actual pressure to figure out if your CP3 is on its way out.
how do I log it?
  Reply With Quote
Old 01-17-2019, 07:59 AM   #18
tylerltr450
 
tylerltr450's Avatar

Name: tylerltr450
Title: Wanna Be Hacker
Status: Not Here
Join Date: Aug 2014
Location: Coal Region, PA
Member`s Gallery
Posts: 168
do you have an autocal from Anarchy?
__________________
2006 Red 5.9 Traction Bars, S&B Intake, ATS intake horn, EFI Live, Borg Warner S363 Turbo, Industrial Injection 60hp Injectors. Auto to nv5600(Complete). SBC 3600

Custom EFI Live Tuning
FullPullPerformance@gmail.com
  Reply With Quote
Old Yesterday, 09:07 PM   #19
SixOhh
 
SixOhh's Avatar

Name: SixOhh
Title: EPA unfriendly
Status: Not Here
Join Date: Aug 2008
Location: Magnolia, TX
Member`s Gallery
Posts: 1,084
If he doesn't know what hes looking at its even harder to diagnose.

as far as a stock LP goes, i have seen several stock pumps that make only 7-10 psi @ idle and never hold more than 5 psi under any load. even mostly stock.

Todd will tell you he doesn't want any more than 10 psi coming into a street pump. more is not better, the pump just needs 5 or 10 psi so that its not having to ask for the fuel or pull the fuel in.

rail pressure is a good indicator as stated above. you need to watch RP as your driving under a load.

You only have a 16' trailer.... that truck shouldn't even notice it much. how does the truck act unloaded when you get on it?

quit guessing and get a gauge on that LP!!!!
__________________
07' Silver 2500 5.9 4x4 LWB
Goerend 48re-csp5/EFI- T&C Mild Cp3-F1 Apex 7.5 -S369sxe Amsoil
Coolant Bypass -Airdog-D&J- Hamilton 188/220 -AFE-ARP Opti-Lube
H-Town Off-Road
  Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 09:53 AM.

 


Powered by vBulletin
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright ©2006 - 2019, CompetitionDiesel.com
all information found on this site is property of www.competitiondiesel.com