Advertisement
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Home Who's Online Today's Posts HP Calculator CompD Gift Shop Mark Forums Read
Go Back   Competition Diesel.Com - Bringing The BEST Together > Tech Area- Dodge > Dodge Tech > 03-07 3rd Gen.
Register Members List Timeslips EFI Live Library Invite Your Friends FAQ Calendar Mark Forums Read

Closed Thread
 
Thread Tools
Old 02-22-2011, 03:23 PM   #1
Grenade
 
Grenade's Avatar

Name: Grenade
Title: Green Behind the Ears
Status: Not Here
Join Date: Oct 2010
Location: Missouri
Member`s Gallery
Posts: 95
2006 tach problems.

My buddy has a 2006 dodge and is having some weird tach issues. At idle it will read around 200 rpms. When driving on the highway going 70mph it will peg at almost 3400 rpm and fluctuate up or down. He took it to dodge and they replaced the cp3 which didnt fix the tach. I have heard some people say its the cam position sensor or the whole instrument panel. Any opionions guys?
Thanks for any help
Cody
__________________
2001 cummins rclb 4x4
 
Old 02-22-2011, 03:37 PM   #2
AH64ID
 
AH64ID's Avatar

Name: AH64ID
Title: Too Much Time
Status: Not Here
Join Date: Dec 2008
Member`s Gallery
Posts: 881
It is common for 06's to have that issue, its normaly the instrument cluster.
__________________
2005 Cummins, QCLB, 4x4, NV5600, GT3782R, Hamilton 178/208, Smarty UDC, BBi Stage 1

 
Old 02-22-2011, 07:00 PM   #3
06 DIESEL
 
06 DIESEL's Avatar

Name: 06 DIESEL
Title: Dead Eye Firearms LLC
Status: Not Here
Join Date: Sep 2007
Location: Middle River, MD
Member`s Gallery
Posts: 3,868
Very common on the 06 trucks, mine is never correct either. Its the cluster, whole thing needs replaced.
__________________
Travis

My rig - 06 Dodge Ram 2500 CTD

My DD - 06 VW Jetta TDI

My toy - 95 Jeep Cherokee

My Classic - 79 Chevy Silverado

My Project - 67 IH Loadstar 1600 4x4

My tractors - 64 Farmall 504 Diesel and 51 Farmall Super C with factory C-72 grader blade
 
Old 02-22-2011, 07:30 PM   #4
01smoker

Name: 01smoker
Title: Diesel Enthusiast
Status: Not Here
Join Date: Nov 2006
Location: Central MO
Member`s Gallery
Posts: 961
is it just on the 06 trucks?
 
Old 02-22-2011, 07:30 PM   #5
AH64ID
 
AH64ID's Avatar

Name: AH64ID
Title: Too Much Time
Status: Not Here
Join Date: Dec 2008
Member`s Gallery
Posts: 881
Quote:
Originally Posted by 01smoker View Post
is it just on the 06 trucks?
As a common failure, yes.
__________________
2005 Cummins, QCLB, 4x4, NV5600, GT3782R, Hamilton 178/208, Smarty UDC, BBi Stage 1

 
Old 02-23-2011, 08:32 AM   #6
chizwizdiz
 
chizwizdiz's Avatar

Name: chizwizdiz
Title: Master Lurker
Status: Not Here
Join Date: May 2008
Location: Saint Clair Shores, MI
Member`s Gallery
Posts: 489
The dealer replaced my cluster twice, and I replaced the cluster once with a used unit.

Damn 2006's.
__________________
I'm Josh, and that was my
 
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 03:57 PM.

 
Powered by vBulletin Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.3.8.6
Copyright ©2006 - 2014, CompetitionDiesel.com
all information found on this site is property of www.competitiondiesel.com